Home > Undefined Reference > Undefined Reference To X264_encoder_open_142

Undefined Reference To X264_encoder_open_142

Contents

Last edited by sumeet inani; 07-26-2010 at 03:43 AM. You cannot have those comments in the middle. The files in /etc are owned by root, so you need to run your editor as root. I looked everywhere I could, but I didn't find an answer to my problem. his comment is here

Looking forward to your comments on it. Did you follow the guide word-for-word or did you modify anything? However, i wonder why if i'm downloading the "actual" ffmpeg source (as commented on above script), the resulting ffmpeg version seems old: "ffmpeg version 1.0.10 Copyright (c) 2000-2014". Aborting package creation. my site

Undefined Reference To X264_encoder_open_142

Muhsin March 14, 2013 at 10:13 am Hi All, I have followed all steps succesfully for instiling opencv, after I typed the last statement: g++ `pkg-config opencv -cflags` my_code.cpp -o my_code Can I use this tutorial somehow? Thanks for the info. Guy Osman Eralp December 21, 2012 at 9:03 pm Yes, the configure did work if you see that shared and PIC are "yes".

john October 5, 2012 at 3:28 pm i have same problem and i have tried using 64 bit configuration. Cheers. Tell linux where the shared libraries for OpenCV are located by entering the following shell command: export LD_LIBRARY_PATH=/usr/local/lib Add the command to your .bashrc file so that you don’t have to Ffmpeg Install I have tried all the process from the start but still fail on make at the same stage: /usr/local/lib/libavcodec.a(libx264.o): In function `X264_init': /home/guy/Documents/work/src/ffmpeg-0.11.1/libavcodec/libx264.c:478: undefined reference to `x264_encoder_open_124′ collect2: ld returned 1

sudo apt-get update
sudo apt-get install build-essential checkinstall git cmake libfaac-dev libjack-jackd2-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev libva-dev libvdpau-dev libvorbis-dev libx11-dev libxfixes-dev libxvidcore-dev texi2html yasm zlib1g-dev Download and install gstreamer. Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148' In the standard Ubuntu install, the opencv.conf file does not exist; you need to create it. Mayank December 28, 2012 at 3:18 am Hey Osman, I installed OpenCV 2.4.3 by following your procedure. Check This Out But, I'm in a trouble: giang @ ubuntu: ~ / src $ cd OpenCV-2.4.2 / giang @ ubuntu: ~ / build $ cd src/OpenCV-2.4.2 giang @ ubuntu: ~ / src/OpenCV-2.4.2/build $

When ‘make'ing OpenCV-2.4.2, the matchers.cpp file has a header Eigen/Array. btw the dir structure is as under /home/nishith/x264 -- after a okay compilation and installation /home/nishith/ffmpeg -- the config step worked fine but the make is giving above error. If you try it, please let me know the results! Yeipis June 16, 2012 at 6:36 am Thanks Ivan, that worked for me too… regards Yeipis Evgheny June 17, 2012 at 5:21 am Thanks, Ivan.

Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148'

after 29% this is the message I get: Linking CXX shared library ../../lib/libopencv_highgui.so /usr/bin/ld: /usr/local/lib/libavcodec.a(avpacket.o): relocation R_X86_64_32S against `av_destruct_packet' can not be used when making a shared object; recompile with -fPIC look at this web-site please help me! Undefined Reference To X264_encoder_open_142 vBulletin ©2000 - 2016, Jelsoft Enterprises Ltd. Undefined Reference To `x264_encoder_open_146' Spaced-out numbers Why doesn't compiler report missing semicolon?

Try deleting the build directory and running cmake again. 3. http://cygnussoft.com/undefined-reference/lex-yy-c-undefined-reference-to-yywrap.html the ffmpeg install comes only at stage 8… any idea why the make of x264 fails ? Gabe December 26, 2012 at 9:51 am Hi Osman, I did exactly what you describe in this page and everythinig works fine, until I try to create a video using CvVideoWriter. Chris Nielsen August 27, 2012 at 10:49 pm Great article mate, I can't believe what an ordeal it is to get OpenCV up and running. Ffmpeg X264

His web site is http://www.samontab.com/ FakeOutdoorsman’s posted an excellent dependency install guide, which is located on the Ubuntu forums: http://ubuntuforums.org/showthread.php?t=786095 163 comments to A Comprehensive Guide to Installing and Configuring OpenCV I am afraid I am doing a simple typo here, but can`t see it and it is driving me crazy. But I tried some older code and I got the following error: /usr/bin/ld: cannot find -lcv /usr/bin/ld: cannot find -lcxcore /usr/bin/ld: cannot find -lml /usr/bin/ld: cannot find -lhighgui /usr/bin/ld: cannot find weblink Brandao June 25, 2012 at 1:02 pm You need install mac port Brandao June 25, 2012 at 3:30 pm http://guide.macports.org/chunked/installing.macports.html nayan June 22, 2012 at 1:49 am i am a learner.

Osman Eralp June 19, 2012 at 8:18 pm Try using the instructions for 64 bit systems. Osman Eralp November 5, 2012 at 9:52 pm Just before the error you show, did you get something like this: /usr/bin/ld: /usr/local/lib/libavcodec.a(avpacket.o): relocation R_X86_64_32S against `av_destruct_packet’ can not be used when sudo apt-get install libgstreamer0.10-0 libgstreamer0.10-dev gstreamer0.10-tools gstreamer0.10-plugins-base libgstreamer-plugins-base0.10-dev gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad gstreamer0.10-ffmpeg Download and install gtk.

Try this: Code: sudo apt-get remove libx264-dev cd ~/ffmpeg make distclean git pull Now continue with the FFmpeg ./configure command as shown in the guide.

but i still have same error. This may fix it: Code: cd ~/ffmpeg make distclean git pull Now, once again, continue with the ./configure command. Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Official Flavours Support Multimedia Software [ubuntu] ffmpeg build issues: libx264 Having Any ideas?

Regards, Muhsin Osman Eralp March 14, 2013 at 10:28 am Yes, you were successful. Did you skip that step? All went well. check over here Works fine now.

The opencv build is confused. Without it it give an error at 17% /usr/bin/ld: /usr/local/lib/libavcodec.a(avpacket.o): relocation R_X86_64_32S against `av_destruct_packet’ can not be used when making a shared object; recompile with -fPIC /usr/local/lib/libavcodec.a: could not read symbols: It simplified my job. If yes, try removing libjpeg and installing it again: sudo apt-get remove libjpeg8 libjpeg8-dev sudo apt-get install libjpeg8 libjpeg8-dev Venkat June 21, 2012 at 8:03 am Thank you so much for

Join Date Mar 2008 Beans 54 ffmpeg build issues: libx264 I tried to get the latest source from ffmpeg today and configure/install it. so again, thanks a lot!!!I am really new to this and finally I got this! Osman Eralp December 9, 2012 at 9:58 am It sounds like you are not in the v4l directory. thanks in advance nishith Adv Reply March 25th, 2011 #6 FakeOutdoorsman View Profile View Forum Posts Private Message 5 Pints of Stout Join Date Sep 2006 Beans 3,713 Re: ffmpeg

Did you download ffmpeg 0.11 or 0.11.1? I have seen situation where a failed build interferes with subsequent builds. If the latest version fails, report the problem > to > >> the > >> >> > ffmpeg-user at ffmpeg.org mailing list or IRC #ffmpeg on > >> irc.freenode.net. > >> Make sure you are in the same directory as my_code, and run it by typing its name: ./my_code Amey September 19, 2012 at 3:21 pm Hi Osman, I have tried compiling

After my new GIT update today building FFMPEG fails me with an error related to an xvid part. After fixing the two problems, build opencv again. Tango Icons © Tango Desktop Project.