Home > Undefined Reference > Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148'

Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148'

Contents

However, some questions remain unanswered. apt-get remove x264 -> apt-get remove x264 x264-dev Then success. That's the reason I would like to compile it by myself. I prefer being able to watch Netflix properly than having an up-to-date ffpmeg. http://cygnussoft.com/undefined-reference/undefined-reference-to-x264-encoder-open-142.html

Results 1 to 2 of 2 Thread: ffmpeg build issues: libx264 Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid Mode Switch to Threaded Mode Maybe your ffmpeg source is out of date? MJunghenn commented May 3, 2016 Got following error on running the full-ffmpeg.sh from another bash script. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148'

gcc -Wshadow -O3 -ffast-math -Wall -I. -I. -std=gnu99 -mcpu=cortex-a8 -mfpu=neon -I/usr/local/include -I/usr/local/include -fPIC -fomit-frame-pointer -fno-tree-vectorize -c -o x264.o x264.c x264.c: In function 'print_csp_names': x264.c:445:15: error: variable 'i' has initializer but incomplete I also have it installed on somewhere else. Do you want to improve the quality ? 1 Haz 2015 22:10 tarihinde "teknoid" yazdı: … I've got the same error, a "make clean" && "./configure" again did it. Your command should be continous and without any comments.

In my github, I provided *.deb package for FFmpeg on A20. sumeet inani View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by sumeet inani View Blog 07-27-2010, 12:43 AM #11 sumeet inani Member Join our community today! Ffmpeg Install When decerasing -qp the quality get's better but the file will be inadequate larger.

User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License. Your linking paths should give the path to the location where libx264 is, right? Do a ls -l to check. go to this web-site Since I have libx264.a and libffmpeg.so with me, only thing that remains is to link them and obtain a ffmpeg library that would allow me to proceed with my application.

If it is not in the man pages or the how-to's this is the place! I use it to make timelapse video from Logitech 910 captured 1280x720 jpeg images: ffmpeg -f image2 -i /work/%*.jpg -r 25 -pix_fmt nv12 -qp 28 -c:v cedrus264 -c:a
none -f mp4 Reload to refresh your session. make: *** [libavdevice/v4l.o] Error 1 make: *** Waiting for unfinished jobs.... /home/mehmet/Android_NDK_r7b/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86/bin/arm-linux-androideabi-ar: creating libavcodec/libavcodec.a /home/mehmet/Android_NDK_r7b/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86/bin/arm-linux-androideabi-ld: cannot open output file ./androidIncludeTrialsNDK7/armv7-a/libffmpeg.so: No such file or directory I have x264 installed in my

Undefined Reference To X264_encoder_open_142

I am using Ubuntu with a virtual machine under Windows 7. https://lists.ffmpeg.org/pipermail/ffmpeg-user/2013-September/017597.html my question was i installed latest x264 (via git) . Libavcodec/libavcodec.so: Undefined Reference To `x264_encoder_open_148' sumeet inani View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by sumeet inani View Blog 07-26-2010, 02:46 AM #2 bathory LQ Guru Undefined Reference To `x264_encoder_open_146' Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox.

But when I install and test it I get high bitrates like the alcantor's version (without P frames) produces. this content You signed out in another tab or window. If the latest version fails, report the problem to theffmpeg-user at mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net. Still the output same as before. Ffmpeg X264

When I use your .deb then everything works fine, I get moderate bitrates when using -qp 28 so I assume the .deb uses P-Frames, the self-compiled not. libavcodec/libavcodec.a(libx264.o): In function `X264_frame': /home/mehmet/ffmpeg-0.10.4/libavcodec/libx264.c:159: undefined reference to `x264_picture_init' /home/mehmet/ffmpeg-0.10.4/libavcodec/libx264.c:179: undefined reference to `x264_encoder_reconfig' /home/mehmet/ffmpeg-0.10.4/libavcodec/libx264.c:191: undefined reference to `x264_encoder_encode' /home/mehmet/ffmpeg-0.10.4/libavcodec/libx264.c:197: undefined reference to `x264_encoder_delayed_frames' libavcodec/libavcodec.a(libx264.o): In function `encode_nals': /home/mehmet/ffmpeg-0.10.4/libavcodec/libx264.c:196: undefined reference Embed Embed this gist in your website. weblink Otherwise, I get the following erros. ./buildnew.sh: line 35: --extra-cflags=-I/usr/local/include: No such file or directory ./buildnew.sh: line 38: --extra-ldflags=-L/usr/local/lib: No such file or directory ./buildnew.sh: line 40: --disable-everything: command not found

What is the 'dot space filename' command doing in bash? I am getting a build error on this: Code: gcc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I. -I"/usr/local/src/ffmpeg" -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 -fasm -std=c99 -fomit-frame-pointer -pthread -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wcast-qual -Wwrite-strings -O3 sumeet inani View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by sumeet inani View Blog Page 1 of 2 1 2 > Thread

Louris84 commented May 24, 2016 I got the following error during ./configure --enable-static --enable-shared: "No working C compiler found" And in the config.log: Failed commandline was: gcc conftest.c -m64 -Wall -I.

Join them; it only takes a minute: Sign up Yet another ffmpeg/libx264 issue up vote 1 down vote favorite My current situation is; ffmpeg and libx264 has been compiled for Android, bathory View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by bathory 07-26-2010, 03:36 AM #3 sumeet inani Member Registered: Oct 2008 Posts: Best. Last edited by adam35413; August 27th, 2008 at 09:03 PM.

You signed in with another tab or window. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. CC libavcodec/libvpxdec.o CC libavcodec/libvpxenc.o CC libavcodec/libx264.o CC libavcodec/libxvid.o libavcodec/libxvid.c: In function ‘xvid_encode_init': libavcodec/libxvid.c:362: error: ‘xvid_plugin_lumimasking_t' undeclared (first use in this function) libavcodec/libxvid.c:362: error: (Each undeclared identifier is reported only once libavcodec/libxvid.c:362: check over here make distclean configure --bla-bla make Regards. -- ffmpeg-user random tip #20 Draw a text into a video: ffmpeg -i silence.mpeg -vhook '/home/stefano/lib/vhook/drawtext.so \ -f /usr/share/fonts/truetype/verdanab.ttf -t hello_world_this_is_very_cool\ -c #ffffff -C #0000ff

The "\" operator does not work from comments. If I change it to usr/local/lib, it can't find libx264. I have made some progress but encountered new errors, thanks to Murphy's Laws. Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Official Flavours Support Multimedia Software [ubuntu] ffmpeg build issues: libx264 Having

Reload to refresh your session. Aborting package creation. But befor recompile x264 remove old > > version of ffmpeg install new version git of x264 and recompile ffmpeg and > > install > > I removed old versions of Having a problem logging in?

But I copied them over manually, and ffmpeg stopped complaining it couldn't find them (the complaints were one at a time, on ffmpeg execution) libavdevice.so.55 libavdevice.so libavcodec.so.55 libswscale.so.2 libswresample.so.0 libpostproc.so.52 libavutil.so.52 If you'd like to contribute content, let us know. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. Introduction to Linux - A Hands on Guide This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started

Did you try it? 2015-04-03 15:32 GMT+03:00 aRUNTU : … Hi, any hint about this???: ***@***.***:/etc/aruntu-extras/programs/FFmpeg-Cedrus-master$ sudo make -j2 && sudo make install LD ffmpeg_g libavcodec/libavcodec.a(cedrus264.o): In function cedrus264_encode_init': /etc/aruntu-extras/programs/FFmpeg-Cedrus-master/libavcodec/cedrus264.c:218: undefined Please visit this page to clear all LQ-related cookies. Main Menu LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug Syndicate Latest Does anyone have any ideas?

For details and our forum data attribution, retention and privacy policy, see here Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 4 Star 11 Fork 10 stulluk/FFmpeg-Cedrus Code Issues 6 Pull requests 0 Projects Now I am in holiday, I will be back in 5 days. The previous version I successfully build was: N-54783-ga0b7e73 from somewhere in June.

Then run ldconfig and try to build again ffmpeg (after running of course make distclean) Regards bathory View Public Profile View LQ Blog View Review Entries View HCL Entries Find Sieve of Eratosthenes, Step by Step Kio estas la diferenco inter scivola kaj scivolema? jeison at jeison-laptop:~/ffmpeg$ make libavcodec/libvorbis.c:257: warning: initialization discards qualifiers from pointer target typeCC libavcodec/libx264.olibavcodec/libx264.c: In function ‘X264_frame':libavcodec/libx264.c:92: error: implicit declaration of function ‘x264_picture_init'libavcodec/libx264.c:104: error: ‘X264_TYPE_KEYFRAME' undeclared (first use in this function)libavcodec/libx264.c:104: I have tried changing the path $x264 to point out to home/mehmet/x264 folder, but I get the same error.